[SciPy-user] Undefined symbol __MAIN__: Help needed with Scipy on OS X

Bill Northcott w.northcott at unsw.edu.au
Mon Oct 10 20:57:17 CDT 2005

On 11/10/2005, at 1:40 AM, Rick Muller wrote:
> PROBLEM FIXED. Here's what I did wrong:
> I'm using gcc 4.0.0 (which is the default under Xcode2, I believe),
> and g77 3.4.3. I'm using Python 2.3.5 (the "framework" build on OS X).
> The problem arises from the scipy_distutils package. When I try to
> install the packages using the stock distutils I get the error  
> message:
> /usr/bin/ld: can't locate file for: -lcc_dynamic
> collect2: ld returned 1 exit status
blah blah

> I tried commenting out this line. That's a bad idea, and leads to the
> problem I reported. However, when I just removed the "-lcc_dynamic"
> part, it worked. Up until the time that I hit what looks like the
> standard scipy/gcc 4.0.0 bugs. Sigh. But at least the install and the
> f2py stuff is working now
This is not a bug.  It is a documentation issue.

To say for the n th time, g77 is NOT part of gcc-4.x compilers and is  
NOT compatible with them.  This is not a bug.  It is intentional.   
The Fortran compiler in gcc-4.x is gfortran, which unfortunately is  
not quite ready for production use.

So if you want use g77 on MacOS X just make gcc-3.3 the default  
compiler by running 'sudo gcc_select 3.3' before starting the build.   
Then all these problems go away.

Bill Northcott

More information about the SciPy-user mailing list