[SciPy-user] Weave under OSX 10.4

Robert Kern rkern at ucsd.edu
Wed Oct 12 10:52:32 CDT 2005

J. Stark wrote:
> I haven't used weave for a while, and in particular not since I 
> upgraded to OSX 10.4. Now I find that scripts which worked fine 
> previously fail to compile - the error messages start with
> ... Numeric/arrayobject.h : No such file or directory
> A search of my hard disk fails to find arrayobject.h.
> Is this a know problem, or am I doing something stupid? I have set 
> gcc to 3.3, rather than the default 4, and run the Tiger Python fix 
> from http://undefined.org/python/

You installation of Numeric is broken (and BTW, yes, you should stick
with gcc 3.3). Are you using the system Python 2.3.5? If so, then I
suspect that when /System/Library/Frameworks/Python.framework got
upgraded, the Numeric headers that were installed there went *poof*, too.

Reinstall Numeric, and the headers should be installed again.

Robert Kern
rkern at ucsd.edu

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter

More information about the SciPy-user mailing list