[SciPy-user] begging for binaries

Robert Kern rkern at ucsd.edu
Thu Oct 13 12:47:58 CDT 2005

Mathew Yeates wrote:
> Robert Kern wrote:
>>Mathew Yeates wrote:
>>>it went nowhere. I have very little experience with scipy's build process.
>>>Python24 was released almost a year ago. Its a shame that it can't be used.
>>Can you give us some more information? Exactly what did you do? What
>>didn't work? Did things fail to compile? link? run?
> Searched for references to msvcrt in scipy_distutils. Didn't find it.
> This isn't a problem I can solve.

It's not a problem I can solve either, but I'm trying. Please try the

Find the gcc specs file. If gcc.exe is %mingwpath%\bin\gcc.exe, and the
version is %mingwversion%, then the specs file should be
$mingwpath%\lib\gcc\%mingwversion%\specs . Change "-lmsvcrt" to

Now, edit scipy_distutils/mingw32ccompiler.py at around line 102 or so:

        # no additional libraries needed


        # no additional libraries needed

Robert Kern
rkern at ucsd.edu

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter

More information about the SciPy-user mailing list