[SciPy-user] ubuntu gcc-4.0 vs. weave

Ryan Krauss ryanlists at gmail.com
Sat Oct 15 03:22:08 CDT 2005

I have scipy installed on ubuntu linux 5.04 and 5.10 (I know, I need
to pick an OS and stick with one - I am getting close).  My test code
runs perfectly in 5.04.  The only thing that is not working in 5.10 is
weave.  I have a chunk of code with a switch for python or weave and
if I set it to python everything is good.  When I set it to weave I
get this message:
CompileError: error: Command "g++ -pthread -fno-strict-aliasing
-DNDEBUG -g -O3 -Wstrict-prototypes -fPIC
-I/usr/include/python2.4 -c
-o /tmp/ryan/python24_intermediate/compiler_fcf4821de2ee87a8ad4d6579aeaebbc9/home/ryan/.python24_compiled/sc_7ca2e4310456126e0a9e56dc59b628f613.o"
failed with exit status 1
WARNING: Failure executing file: <datafit_main.py>

I assume this is some gcc(or g++) 4.0 problem.  I saw a post from
August that Robert Kern updated to the new blitz and got 4.0 to work
with weave.  He mentioned something about ./configure.  I installed
the blitz++  package (1.0.....) from the ubuntu package manager.  It
put a lot of stuff in /usr/include/blitz.  I did not see a configure
file.  I tried copying the blitz folder as Robert mentioned, but got
the same message.  I even tried going into /usr/bin and modifying the
gcc and g++ symbolic links to point to version 3.4.  This actually
lead to a successful compile, but using the code caused some sort of
IPP error from a python 2.4 thread.

I am willing to work with ubuntu 5.04 if that is necessary, but if I
can get over this last hurdle it would be nice to use 5.10.  (I
honestly don't know why I have gotten so much further with ubuntu's
gcc-4.0 as opposed to fedora's.)  Can anyone tell me how to make weave
and ubuntu's gcc-4.0 work together?  Can it be done?



More information about the SciPy-user mailing list