[SciPy-user] ubuntu gcc-4.0 vs. weave

Ryan Krauss ryanlists at gmail.com
Sat Oct 15 10:08:33 CDT 2005

Thanks Stefan.  I guess I wasn't paying close enough attention to the
package name.  But it still didn't work.  I downloaded 0.9 from their
website and did a configure, then make lib, then make install, and
copied the directory as before but get the same error:
CompileError: error: Command "g++ -pthread -fno-strict-aliasing
-DNDEBUG -g -O3 -Wstrict-prototypes -fPIC
-I/usr/include/python2.4 -c
-o /tmp/ryan/python24_intermediate/compiler_fcf4821de2ee87a8ad4d6579aeaebbc9/home/ryan/.python24_compiled/sc_7ca2e4310456126e0a9e56dc59b628f614.o"
failed with exit status 1
WARNING: Failure executing file: <datafit_main.py>

Are you running scipy under Breezy?  Does weave work for you?



On 10/15/05, Stefan van der Walt <stefan at sun.ac.za> wrote:
> Hi Ryan
> On Sat, Oct 15, 2005 at 04:22:08AM -0400, Ryan Krauss wrote:
> > the blitz++  package (1.0.....) from the ubuntu package manager.  It
> > put a lot of stuff in /usr/include/blitz.  I did not see a configure
> > file.  I tried copying the blitz folder as Robert mentioned, but got
> > the same message.  I even tried going into /usr/bin and modifying the
> > gcc and g++ symbolic links to point to version 3.4.  This actually
> > lead to a successful compile, but using the code caused some sort of
> > IPP error from a python 2.4 thread.
> The Blitz package that comes with Ubuntu (Breezy) is named blitz++
> (1:0.8-4).  Version 0.8 of Blitz++ does not compile with g++4.  You
> will have to get the 0.9 sources from their homepage.
> I don't know if this will actually solve your problem, though.
> Regards
> Stéfan
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-user

More information about the SciPy-user mailing list