[SciPy-user] More installation troubles

Alexander Borghgraef alexander.borghgraef.rma at gmail.com
Tue Sep 13 06:50:51 CDT 2005

On 9/9/05, Todd Miller <jmiller at stsci.edu> wrote:
> On Thu, 2005-09-08 at 07:43, Pearu Peterson wrote:
> > On Thu, 8 Sep 2005, Alexander Borghgraef wrote:
> >
> > <snip>
> > > Yep. Removing numarray solved that problem. Now I'm back to the 
> include
> > > problem described in my other post.
> I had some comments and questions about this:
> 1. numarray and Numeric/scipy coexist fine for me. numarray can't yet
> replace Numeric in scipy but using both has not been a problem.
> 2. I can't reproduce the problem with Numeric importing numarray's
> dotblas during scipy setup but if there is one, we want to fix it.
> What's your OS and compiler toolset? 

Fedora core 2, gcc/++/77 version 3.4.4, python 2.3.4 

What versions of
> numarray/Numeric/scipy did you install?

I installed numarray 1.3.3, Numeric 24.0b2, scipy 0.3.2 from source. 

3. Has anyone else ever seen a problem with numarray's dotblas
> conflicting with Numeric's dotblas during scipy installation?

Well, I tried installing numarray again, and the conflict doesn't even need 
scipy. When running the line 
"import Numeric" in idle I got the following errors:

Traceback (most recent call last):
File "<pyshell#0>", line 1, in -toplevel-
import Numeric
line 358, in -toplevel-
from dotblas import dot, innerproduct, vdot
line 5, in -toplevel-
import generic as _gen
line 13, in -toplevel-
import numerictypes as _nt
line 168, in -toplevel-
Byte = _register("Byte", Int8)
line 68, in _register
raise ValueError("Type %s has already been registered" % name)
ValueError: Type Byte has already been registered

Alex Borghgraef
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.scipy.net/pipermail/scipy-user/attachments/20050913/9d8d154e/attachment.htm

More information about the SciPy-user mailing list