[SciPy-user] Problems Installing SciPy on OS X 10.4.2 w/ python 2.3.5

Zane Crawford zane-scipy at ideotrope.org
Fri Sep 30 11:44:06 CDT 2005

With much frustration, and some patient help from Chris Fonnesbeck, I
have been trying to get SciPy installed on my Mac.

I am running OS X 10.4.2, and am attempting to use the stock python
(2.3.5) which is installed by the Apple developer tools.  I believe I
have all of the underlying dependencies installed and functioning
(Numeric 24.0b2, AquaTerm 1.0b2, fftw, GnuPlot 4.0.0, F2PY, and probably
other things I installed along the way), and am now running into
problems with the actual build of SciPy itself.  I have just tried three
different ways:

1) I installed a binary package which Chris created for me, built on python
   2.3.5.  It installs fine, and I can "import scipy" without issues,
   however, I can't use anything from it, because of the __cvs_version__
   bug, which is referred to in the mailing list archives, but which was
   apparently not fixed in a persistent way. (it seems there was some
   clever code which allowed the software to keep track of its own
   version based on the CVS versions of the files, but this became
   broken when the source was migrated to SVN?)

2) I tried to build the last CVS version of SciPy, from July 29th,
   2005.  This fails almost immediately, regardless of whether I'm using
   GCC 3.3 or GCC 4.0, with an error from posixpath.py, line 77:
   i = p.rfind('/') + 1
   AttributeError: 'NoneType' object has no attribute 'rfind'

3) I tried pulling the most recent version of the source from SVN.  This
   seems to get much further than the CVS build, but fails eventually:

   In file included from Lib/xplt/src/play/all/hash0.c:8:
   #error destroy this config.h and rerun configure script

   However, there are many many warnings prior to this failure, and I
   don't know what the acutal problem is

I've completely removed (as far as I can tell) all installed SciPy
packages (from Chris' build) and think I have a clean 2.3.5 python
environment ready to install SciPy.  If anyone has any other sources
they would recommend building from, I'm happy to try.  My initial
attempt to install SciPy (prior to this mess) was via Fink, which seemed
to result in its own problems.

Zane A. Crawford        .    +    zane at ideotrope.org
Amateur Human        *   ,     *  https://ideotrope.org
Boulder, Colorado        __o      
work : 303.735.3729    _`\<,_    "Here we are, trapped in the
cell : 303.815.6866   (*)/ (*)    amber of the moment. There
PGP  : 0x55E0815F                 is no why."
                                            -- Kurt Vonnegut

More information about the SciPy-user mailing list