[SciPy-user] scipy.test() crashes under win2k

weg werp wegwerp at gmail.com
Sun Apr 23 12:25:18 CDT 2006

Hi group,

I finally tried to install scipy. Everything appears to work, but
scipy.test() crashes.

I installed the prebuilt versions:
first numpy-0.9.6r1.win32-py2.4.exe, then
scipy-0.4.8.win32-py2.4-pentium3.exe (I assume that Pentium 4/SSE2
does not work on my Athlon).

import numpy;numpy.test()
works fine, but
import scipy;scipy.test()
first gives some warnings about overwriting fft, then runs all the
tests ok, then shows a lot of dots (file test?) and crashes (drwatson
log available).

Any ideas?

win2k sp4, Athlon XP 1700+, 768 MB
Python 2.4 (#60, Nov 30 2004, 09:34:21) [MSC v.1310 32 bit (Intel)] on win32

Other point, slight nitpick for the website: it took my a few minutes
to figure out the difference between the download and the install
sections on the scipy website. In the download section I see some
executables for windows, which is what I want as a newby. I then went
to 'install' and expected some installation guidelines, but this seems
more like an instruction for compiling from source  (instant newby
panic). Could the difference be made a little bit more clear? A few
words are probably ok:
-download section: 'these are prebuilt versions, for the latest
version you have to compile yourself, see install'.
-install section: 'installing from source, to download a prebuilt
stable version see download'


I tried to send this message without subscribing to the list, but it
got probably stuck in moderator approval. Is the policy to allow no
posts from non-subscribers? If so, this should be stated on the

More information about the SciPy-user mailing list