[SciPy-user] OSX Issue -- Symbol not found: _fprintf$LDBLStub

Tony Mannucci Tony.Mannucci at jpl.nasa.gov
Mon Apr 24 22:37:13 CDT 2006

I used to have a very similar problem until I used g77 with gcc 3.3 
(sudo gcc_select 3.3) rather than gcc 4.0. Then the proper libraries 
were searched and the symbol found. The library you are having 
problems with appears to be written in C, so I don't if this applies. 
Make sure you are using the correct gcc by typing gcc_select without 
arguments. I think scipy needs f77 for some modules, so you must have 
a fortran compiler somewhere? I downloaded the binary from Khanna's 
HPC on OS X site, and followed the installation instructions 

Be sure to remove any old SciPy installations before retrying (e.g.
/usr/lib/python2.4/site-packages/scipy or $HOME/lib/python2.4/


>Message: 5
>Date: Mon, 24 Apr 2006 18:03:09 -0700
>From: Gregory Crosswhite <gcross at u.washington.edu>
>Subject: [SciPy-user] OSX Issue -- Symbol not found: _fprintf$LDBLStub
>To: scipy-user at scipy.net
>Message-ID: <19DA9FD8-3927-4FDD-8206-BA72A0D81E0A at u.washington.edu>
>Content-Type: text/plain; charset=US-ASCII; delsp=yes; format=flowed
>Hey!  I'm attempting to get SciPy to run on OSX 10.4 (Tiger), with
>the latest version of Xcode (2.2.1, I believe) installed.  When I run
>python and import scipy.fftpack, I get the following error:
>Python 2.4.3 (#1, Mar 30 2006, 11:02:15)
>[GCC 4.0.1 (Apple Computer, Inc. build 5250)] on darwin
>Type "help", "copyright", "credits" or "license" for more information.
>  >>> import scipy.fftpack
>Traceback (most recent call last):
>    File "<stdin>", line 1, in ?
>    File "/Library/Frameworks/Python.framework/Versions/2.4/lib/
>python2.4/site-packages/scipy/fftpack/__init__.py", line 10, in ?
>      from basic import *
>    File "/Library/Frameworks/Python.framework/Versions/2.4/lib/
>python2.4/site-packages/scipy/fftpack/basic.py", line 13, in ?
>      import _fftpack as fftpack
>ImportError: Failure linking new module: /Library/Frameworks/
>fftpack/_fftpack.so: Symbol not found: _fprintf$LDBLStub
>    Referenced from: /Library/Frameworks/Python.framework/Versions/2.4/
>    Expected in: dynamic lookup
>I've tried both the MacPython binaries distributed at python.org, and
>the ActiveState distribution.  I've tried both downloading and
>installing SciPy binaries (the latest version, 0.4.8, and an older
>version, 0.4.4), and compiling them from source.  The problem does
>not go away whether I use GCC 3.3 or 4.0.
>Now, at one point in the past I had installed and gotten working
>SciPy 0.3 from sources, so there might be a library sitting around
>from that which is screwing things up, but I don't know where to
>look!  Under the belief that maybe the problem was an old version of
>FFTW (or one compiled with GCC version 4.0 instead of 3.3) I
>downloaded, compiled, and installed BOTH FFTW 2.1.5 and 3.1.1 using
>GCC 3.3.  Again, no change in the error message.
>There is exactly one thing that does seem to work, and that is using
>the binary of version 0.4.9 built by Christopher Fonnesbeck,
>downloadable from http://trichech.us/.  I am using that for now, so
>this isn't a terribly urgent issue, but it really bothers me that I
>can't get any other binary or source distribution of SciPy working;
>I wish I could figure out why his build works when even builds
>performed on my own computer won't work.
>Does anyone have thoughts on what could be going wrong?
>Thanks a lot!  :-)
>- Greg

Tony Mannucci
Supervisor, Ionospheric and Atmospheric Remote Sensing Group
  Mail-Stop 138-308,                     Tel > (818) 354-1699
  Jet Propulsion Laboratory,              Fax > (818) 393-5115
  California Institute of Technology,     Email > Tony.Mannucci at jpl.nasa.gov
  4800 Oak Grove Drive,                   http://genesis.jpl.nasa.gov
  Pasadena, CA 91109

More information about the SciPy-user mailing list