[SciPy-user] compiling scipy on Fedora Core 4 -- undefined reference to PyInt_Type

iCy-fLaME icy.flame.gm at gmail.com
Thu Feb 2 12:18:30 CST 2006

On 2/2/06, David Mobley <dmobley at gmail.com> wrote:
> Dear All,
>  I'm sure I've done something stupid, but I haven't been able to turn up
> anything useful with Google, so I need to appeal to the list for help.
>  I'm trying to install scipy under RedHat Fedora Core 4 on a Xeon, and the
> build crashes with a whole bunch of "undefined reference to..." errors when
> it gets to the step of running g77 on various fft and fftpack object and
> shared object libraries. The first error is "In function 'int_from_pyobj':
> build/src/Lib/fftpack/_fftpackmodule.c:109: undefined
> reference to 'PyInt_Type'.
>  Can anyone help? I already have NumPy installed and in my PYTHONPATH, and
> also turned up on the web various suggestions about using lapack/blas/atlas
> even though they're not absolutely required, so I tried with those as well
> as without them (first with just lapack and blas, then adding ATLAS) and
> encountered the same problem every time.
>  Am I missing something eseential?
>  Thanks very much,
>  David Mobley
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-user

Which version of scipy are you trying to build? tried the 0.4.4?

be sure to yum update everything first. also the Numeric package
(python-numeric-23.7-2) for FC4 is kinda out of date, grab the latest
one from sourceforge. Be sure to upgrade your gcc to at least 4.0.2.

I am using FC4 on a P4 machine, the following is what i have, not all
of them are needed.


Numeric 24.2


The body maybe wounded, but it is the mind that hurts.

More information about the SciPy-user mailing list