[SciPy-user] compiling scipy on Fedora Core 4 -- undefined reference to PyInt_Type --follow-up

Robert Kern robert.kern at gmail.com
Fri Feb 3 13:36:09 CST 2006

David Mobley wrote:
> Following up on the below problems, I'm still trying to compile scipy
> 0.4.4 under RedHat Fedora Core 4. I'm now using gcc 4.0.2 and atlas
> 3.6.0-8, blas 3.0-36, lapack 3.0-35, numpy 0.94, numarray 1.4.0, and
> Numeric 24.2. We've also tried on an Opteron (fedora core 4) with no
> success. I'm still getting the same error when I try to compile as before:
>> The first error is "In function 'int_from_pyobj':
> build/src/Lib/fftpack/_fftpackmodule.c:109: undefine d reference to
> 'PyInt_Type'.
> Any further suggestions?

Are you sure that you are picking up Python.h?

> This is all because I'm hoping to install f2py (although I anticipate
> using scipy for other reasons later) to be able to interface with some
> fortran code I'm trying to use for my research relating to computational
> drug design.

Well, if all you need right now is f2py, it's part of numpy, not scipy.

Robert Kern
robert.kern at gmail.com

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter

More information about the SciPy-user mailing list