[SciPy-user] Can't even begin to build/install scipy 0.4.4

Travis Oliphant oliphant.travis at ieee.org
Thu Feb 9 14:55:49 CST 2006

skip at pobox.com wrote:

>We'd been running an old version of scipy (0.3) in our Solaris 8/9/10
>environment.  In preparation for migrating to a new GCC (3.4 from 3.3.2),
>Python (2.4.2 from 2.3.4) and Gtk (2.6 from 2.4), we have been busy
>rebuilding all our libraries and applications.  One application (the one I
>happen to work on) uses a tiny bit of scipy.  The guy doing the building
>tried to build scipy 0.3.2.  That failed.  He got to a certain point but
>found that scipy's distutils apparently fails to honor the --rpath flag.
>I told him I'd take a look at it and decided to try scipy 0.4.4 instead (no
>sense fiddling with an old version that won't build - might as well see if
>the new version is any better).  I downloaded numpy 0.9.4, but can't even
>get help.  For some reason, distutils believes it needs to compile something
>just to give me help:
>What's up with that?

It's the way the configuration was setup.   In the SVN version it 
detects you just want help and doesn't try to compile the little atlas 
program.    If you can please try the SVN version. 

svn co http://svn.scipy.org/svn/numpy/trunk numpy

will give you the latest...

A new release is scheduled in a few days.  We've recently worked out 
other compilation issues.


More information about the SciPy-user mailing list