[SciPy-user] Import probs with rev 1735 svn scipy core

George Nurser agn at noc.soton.ac.uk
Mon Jan 2 06:37:24 CST 2006

On 30 Dec 2005, at 22:55, Travis Oliphant wrote:

> George Nurser wrote:
>> Just tried to get rev 1735 svn scipy core going on an Opteron.
>> Non root install of Scipy, site.cfg to use acml libraries for lapack
>> and blas.
>> LD_LIBRARY_PATH includes acml directory.
>> Otherwise default.
>> python setup.py install --home=...    seems to work fine.
>> But when I try
>> python
>>>>> import scipy
>> Importing ScipyTest of testing to scipy
>> Failed to import base
>> cannot import name ccompiler
>> Importing fft of corefft to scipy
>> Importing ifft of corefft to scipy
>> Failed to import random
>> 'module' object has no attribute 'dtypedescr'
>> Puzzled about  ccompiler message, as ccompile.py seems to be in
>> distutils directory, not base subdirectory.
> Is this a fresh install on the system or are their older
> installations.   Enough has changed in the package loading that I  
> would
> delete any old install and the build directory (if you had a previous
> check-out) and install again.
> Otherwise,  I'm not sure what is going on.
> -Travis

Problem was that I had prepended the scipy install directory onto my  
sys.path. Hence it was trying scipy.distutils routines before the  
python distutils routines.

Putting the scipy install directory at the end of sys.path solved the  
problem. Works fine now. No test failures.

-George Nurser.

More information about the SciPy-user mailing list