[SciPy-user] Scipy builds OK on OSX, but doesn't actually work!

Matthew Vernon matthew at sel.cam.ac.uk
Thu Jan 19 08:02:27 CST 2006


I followed the instructions for installing scipy on OSX, and so built  
the SVN versions. All seemed to go fine, until I actually try and use  

kublai:~ matthew$ python
Python 2.3.5 (#1, Mar 20 2005, 20:38:20)
[GCC 3.3 20030304 (Apple Computer, Inc. build 1809)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
 >>> import scipy
Traceback (most recent call last):
   File "<stdin>", line 1, in ?
   File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/ 
python2.3/site-packages/scipy/__init__.py", line 51, in ?
   File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/ 
python2.3/site-packages/numpy/_import_tools.py", line 196, in __call__
     self.warn('Overwriting %s=%s (was %s)' \
AttributeError: PackageLoader instance has no attribute '_obj2str'

This is using the apple-supplied python.

Any ideas?



Matthew Vernon MA VetMB LGSM MRCVS
Farm Animal Epidemiology and Informatics Unit
Department of Veterinary Medicine, University of Cambridge

More information about the SciPy-user mailing list