[SciPy-user] numpy.test() segfaults with numpy 0.9.8

Sergey Dolgov solkaa at gmail.com
Tue Jun 6 08:09:12 CDT 2006

On 6/5/06, Travis Oliphant <oliphant at ee.byu.edu> wrote:
> Sergey Dolgov wrote:
> >Hi, I've just built numpy 0.9.8 on a Debian box (i386, unstable), and
> >it fails to pass its tests (see below). BTW,  all tests ran fine with
> >previous version 0.9.6 (but it seems like the failing one was
> >introduced only in 0.9.8).
> >
> >
> It's a problem with Python itself.  It is known about and has been fixed
> in Python 2.5 and worked around in SVN version of NumPy.  Most code will
> not excerise where the problem is (using the array scalar constructor
> for complex types directly), so I wouldn't worry about it at this point.

Thanks for your help, Travis. I've tried it with debian python2.5, and
the segfault is still there -- apparently debian's snapshot (20060409)
doesn't include the fix yet.

I won't worry much anyway, as you suggest.


More information about the SciPy-user mailing list