[SciPy-user] scipy build bdist_rpm

Robert Kern robert.kern at gmail.com
Fri Jun 23 22:47:14 CDT 2006

Christian Kristukat wrote:
> Robert Kern wrote:
>> Christian Kristukat wrote:
>>> Hi,
>>> I tried to build a binary rpm using
>>> python setup.py bdist_rpm
>>> on scipy 0.4.9 and get the following error:
>>> building extension "scipy.fftpack._fftpack" sources
>>> Traceback (most recent call last):
>>>   File "setup.py", line 50, in ?
>>>     setup_package()
>>>   File "/usr/lib/python2.4/site-packages/numpy/distutils/command/build_src.py",
>>> line 412, in f2py_sources
>>>     raise ValueError("%r missing" % (target_file,))
>>> ValueError: '_fftpackmodule.c' missing
>>> error: Bad exit status from /home/ck/testarea/rpm/tmp/rpm-tmp.24879 (%build)
>>> RPM build errors:
>>>     Bad exit status from /home/ck/testarea/rpm/tmp/rpm-tmp.24879 (%build)
>>> error: command 'rpmbuild' failed with exit status 1
>>> A normal build however runs without problems.
>> numpy.distutils adds a build_src command that scipy uses extensively. The 
>> command dependencies are sometimes no triggered correctly. Try explicitly 
>> listing the important commands:
>>    $ python setup.py build_src build_clib build_ext build bdist_rpm
> Thanks, but it's still the same or should I remove the 'build' directory first?

No, I just tried that (and then realized that it wouldn't make a difference 
anyways since bdist_rpm runs the build in a separate directory). I noticed that 
the rpm-tmp.* file is a shell script that appears to be what is executed for the 
bdist_rpm. The actual command that gets executed is this:

   env CFLAGS="$RPM_OPT_FLAGS" python setup.py build

That's probably the problem; it's missing the other commands (and since I 
actually had --fcompiler options on some of those commands, that's *really* 
annoying). I'm not too familiar with RPM builds, though, so I don't know which 
component is to blame; likely numpy.distutils should be properly setting up the 
dependency chain of commands such that "python setup.py build" does everything 
correctly. Please enter a ticket in the numpy Trac describing the problem:


Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco

More information about the SciPy-user mailing list