[SciPy-user] minimizers don't work - d1mach problem

Olivier Médoc o_medoc at yahoo.fr
Tue Mar 7 16:09:26 CST 2006

I found this thread in the mailinglist archive.

I seems to get the same error :
scipy 0.4.6 build with a gcc4.0.3 snapshot and gfortran4.0.3 snapshot.

When I run test() I get :

Adjust D1MACH by uncommenting data statements
 appropriate for your machine.
STOP 779

I think this error is an arch specific error (AMD64 ?). Finally I found 
a workaround. I can run the test suite at level 10 without errors :

- I deleted the two d1mach.f files and replaced them with a cfile found 
here :

(the file d1mach.c)
- then adjusted the setup.py files
| sed "s/join('mach','\*\.f')/join('mach','*.f'),join('mach','*.c')/" -i 
sed "s/join('mach','\*\.f')/join('mach','*.f'),join('mach','*.c')/" -i 

|Please note that I considered that it worked because I successfully 
compute the tests at level 10. But I don't know more about this..




Nouveau : téléphonez moins cher avec Yahoo! Messenger ! Découvez les tarifs exceptionnels pour appeler la France et l'international.
Téléchargez sur http://fr.messenger.yahoo.com

More information about the SciPy-user mailing list