[SciPy-user] Installation problem

Ed Schofield schofield at ftw.at
Tue Mar 28 11:42:54 CST 2006

David Huard wrote:
> I had a fine scipy installation and then had the bad idea to change
> something...
> I compiled python from source and then tried to install back numpy,
> scipy and matplotlib. It didn't work out very well for matplotlib, so
> I tried to get back my previous installation, and it doesn't work
> either anymore...
> More precisely, when I import numpy, there is a bunch of error
> messages to the effect that
> PyUnicodeUCS2_FromUnicode
> in mutliarray.so is an undefined symbol.
> Is this a problem related to gcc 4.0 ?
No, this is a problem with whether Python is built using 2-byte or
4-byte unicode representation internally.  My guess is that you've built
Python from source using a different option from what your distribution
provided.  If so, remove the distribution-provided Python before
building NumPy and SciPy, or at least move it away so distutils can't
find it.

See e.g.

-- Ed

More information about the SciPy-user mailing list