[SciPy-user] numpy - scipy version hell

Robert Kern robert.kern at gmail.com
Thu Oct 19 14:19:01 CDT 2006

James K. Gruetzner wrote:
> I'm using Fedora core 5, that insect-laden wonder, which includes python 
> 2.4.3.  I'm trying to install numpy (scipy-core) and scipy (the rest).   I 
> can't seem to get around package conflicts.  I've tried two methods, one in 
> which numpy fails and one in which scipy fails.   This is the "scipy fails" 
> one (I sent the numpy fails one to the numpy-discussions list).  
> METHOD 2 (scipy fails)
> OK, remove the previously installed numpy packages 
> from /usr/lib/python2.4/site-packages.  Now use yum to install numpy 
> 0.9.8-1.fc5 from the extras repository.   Hooray, numpy imports fine!
> So, now time to download scipy, v.0.5.1.  Untarball it and cd.  IT fails to 
> install, with the following (long) error message:

numpy 0.9.8 is quite old compared to scipy 0.5.1. You will want the recent 
1.0rc3 release.

Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco

More information about the SciPy-user mailing list