[SciPy-user] Plea: Installing SciPy on Mac 10.4.9: _fftpack.so problems?

Ariel Rokem arokem@berkeley....
Wed Apr 11 21:32:58 CDT 2007

Thanks Zach and Robert,

I've tried to include more  this time (does the build process save a  
log somewhere?). Please be patient with me, I am just a newbie,  
trying to migrate over from the world of evil proprietary software  
for :)

So - as advised I changed the gcc version to 4.0 and verified that  
was the version.

Then, I ran the building process again, as before:

Along the way, several kinds of error messages appeared:


non-existing path in 'Lib/maxentropy': 'doc'

and this:

Couldn't match compiler version for 'GNU Fortran (GCC) 4.3.0 20070316  
tal)\nCopyright (C) 2007 Free Software Foundation, Inc.\n\nGNU  
Fortran comes wit
h NO WARRANTY, to the extent permitted by law.\nYou may redistribute  
copies of G
NU Fortran\nunder the terms of the GNU General Public License.\nFor  
more informa
tion about these matters, see the file named COPYING\n'
customize Gnu95FCompiler using build_clib
building 'superlu_src' library
compiling C sources
C compiler: gcc -arch ppc -arch i386 -isysroot /Developer/SDKs/ 
MacOSX10.4u.sdk -
fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd - 
-dynamic -DNDEBUG -g -O3

This looks like it may have something to do with the compiler  
versions and yet, it goes on compiling,
More error messages appear - things that look like this:

Lib/linsolve/SuperLU/SRC/scomplex.c: In function 'c_div':
Lib/linsolve/SuperLU/SRC/scomplex.c:30: warning: incompatible  
implicit declaration of built-in function 'exit'

and things that look like this:

fortran:f77: Lib/special/cdflib/dzror.f

       ASSIGN 10 TO i99999
Warning: Obsolete: ASSIGN statement at (1)

Finally, this is the last things that appear on the screen:

creating build/temp.macosx-10.3-fat-2.4/build
creating build/temp.macosx-10.3-fat-2.4/build/src.macosx-10.3-fat-2.4
creating build/temp.macosx-10.3-fat-2.4/build/src.macosx-10.3-fat-2.4/ 
creating build/temp.macosx-10.3-fat-2.4/build/src.macosx-10.3-fat-2.4/ 
creating build/temp.macosx-10.3-fat-2.4/Lib/fftpack/src
compile options: '-DSCIPY_FFTW3_H -I/usr/local/include -Ibuild/ 
meworks/Python.framework/Versions/2.4/include/python2.4 -c'
gcc: build/src.macosx-10.3-fat-2.4/fortranobject.c
gcc: Lib/fftpack/src/zrfft.c
gcc: Lib/fftpack/src/drfft.c
gcc: build/src.macosx-10.3-fat-2.4/Lib/fftpack/_fftpackmodule.c
gcc: Lib/fftpack/src/zfft.c
gcc: Lib/fftpack/src/zfftnd.c
Traceback (most recent call last):
   File "setup.py", line 55, in ?
   File "setup.py", line 47, in setup_package
     configuration=configuration )
   File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
s/core.py", line 174, in setup
     return old_setup(**new_attr)
   File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
9, in setup
   File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
6, in run_commands
   File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
6, in run_command
   File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
s/command/build_ext.py", line 121, in run
   File "/Library/Frameworks/Python.framework/Versions/2.4//lib/ 
.py", line 405, in build_extensions
   File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
s/command/build_ext.py", line 312, in build_extension
     link = self.fcompiler.link_shared_object
AttributeError: 'NoneType' object has no attribute 'link_shared_object'

Looks pretty bad, no?

I ran the installation command too, just to be sure. Unsurprisingly,  
it didn't work, giving this message in the end:

compile options: '-DSCIPY_FFTW3_H -I/usr/local/include -Ibuild/ 
src.macosx-10.3-fat-2.4 -I/Library/Frameworks/Python.framewo
rk/Versions/2.4/lib/python2.4/site-packages/numpy/core/include -I/ 
python2.4 -c'
/usr/local/bin/g77 -g -Wall -undefined dynamic_lookup -bundle build/ 
Lib/fftpack/_fftpackmodule.o build/temp.macosx-10.3-fat-2.4/Lib/ 
fftpack/src/zfft.o build/temp.macosx-10.3-fat-2.4/Lib/fftpa
ck/src/drfft.o build/temp.macosx-10.3-fat-2.4/Lib/fftpack/src/zrfft.o  
.o build/temp.macosx-10.3-fat-2.4/build/src.macosx-10.3-fat-2.4/ 
fortranobject.o -L/usr/local/lib -L/usr/local/lib/gcc/power
pc-apple-darwin7.9.0/3.4.4 -Lbuild/temp.macosx-10.3-fat-2.4 - 
ldfftpack -lfftw3 -lg2c -lcc_dynamic -o build/lib.macosx-10.3-
/usr/bin/ld: can't locate file for: -lcc_dynamic
collect2: ld returned 1 exit status
/usr/bin/ld: can't locate file for: -lcc_dynamic
collect2: ld returned 1 exit status
error: Command "/usr/local/bin/g77 -g -Wall -undefined dynamic_lookup  
-bundle build/temp.macosx-10.3-fat-2.4/build/src.maco
sx-10.3-fat-2.4/Lib/fftpack/_fftpackmodule.o build/temp.macosx-10.3- 
fat-2.4/Lib/fftpack/src/zfft.o build/temp.macosx-10.3-f
at-2.4/Lib/fftpack/src/drfft.o build/temp.macosx-10.3-fat-2.4/Lib/ 
fftpack/src/zrfft.o build/temp.macosx-10.3-fat-2.4/Lib/ff
tpack/src/zfftnd.o build/temp.macosx-10.3-fat-2.4/build/ 
src.macosx-10.3-fat-2.4/fortranobject.o -L/usr/local/lib -L/usr/loc
al/lib/gcc/powerpc-apple-darwin7.9.0/3.4.4 -Lbuild/temp.macosx-10.3- 
fat-2.4 -ldfftpack -lfftw3 -lg2c -lcc_dynamic -o build/
lib.macosx-10.3-fat-2.4/scipy/fftpack/_fftpack.so" failed with exit  
status 1

I hope this gives enough information this time (in fact, I hope  
that's not too much this time). Does anyone have any ideas?

Thanks a lot,


On Apr 11, 2007, at 7:07 PM, Robert Kern wrote:

> Ariel Rokem wrote:
>> Hi - I have been having a very similar problem building scipy.
>> I am running Mac OS10.4.9 on a PPC with gfortran 4.3.0 and gcc3.3
>> I was running:
>> ariel-rokems-ibook-g4:~ ariel$ python setup.py build_src build_clib
>> --fcompiler=gnu95 build_ext --fcompiler=gnu95 build
>> as instructed here : http://scipy.org/Installing_SciPy/Mac_OS_X
>> But it doesn't seem to work:
>> ariel-rokems-ibook-g4:~ ariel$ python
>> Python 2.4.4 (#1, Oct 18 2006, 10:34:39)
>> [GCC 4.0.1 (Apple Computer, Inc. build 5341)] on darwin
>> Type "help", "copyright", "credits" or "license" for more  
>> information.
>>>>> import scipy
>> Traceback (most recent call last):
>>   File "<stdin>", line 1, in ?
>> ImportError: No module named scipy
> Note that after it is built (correctly, see Zach's message), it  
> must then be
> installed per the directions given on that page.
>   $ sudo python setup.py install
> -- 
> Robert Kern
> "I have come to believe that the whole world is an enigma, a  
> harmless enigma
>  that is made terrible by our own mad attempt to interpret it as  
> though it had
>  an underlying truth."
>   -- Umberto Eco
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user

More information about the SciPy-user mailing list