[SciPy-user] Weave inline errors further insight

Michael ODonnell odonnems@yahoo....
Sun Dec 2 23:15:13 CST 2007

I have posted a couple questions regarding the use of weave.inline. Because I have not received any feed back I thought I might provide some more clues to the problem that I am having. 

As a refresher, I have the following versions installed:
I have also installed SDK toolkit and other related modifications (This appears to work)
I also installed MinGW and this appears to work.

First problem: There appears to be a problem with numpy/distutils/exec_command.py. I had to comment out lines 67-70 (there about) in order to properly assign the python executable. Once I do this I get the next error.

Second problem: Will not complete the weave.inline. Example of code here:
a = 1
weave.inline('printf("%d\\n",a);',['a'], verbose=2, type_converters=converters.blitz)

The c++ source file is created; however, the object file is not created. This would make me think there is a problem with the comiler but I have tried both SDK and MinGW and they both cause the same error.

Does anyone have thoughts on why this might be happening. I get the same problem if I insall enthought as well. I will cross-post on numpy too.

Thank you for your assistance,
michael (new user)

Get easy, one-click access to your favorites. 
Make Yahoo! your homepage.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20071202/977193bd/attachment.html 

More information about the SciPy-user mailing list