[SciPy-user] weave and mingw on win xp sp2 bug?

mani sabri mani.sabri@gmail....
Sat Dec 29 02:28:51 CST 2007


Happy holidays

I'm using python 2.4.4 , scipy 0.6.0 , numpy 1.0.4  and mingw gcc 3.4.5 on
win xp sp2 

When I try to run a weave example (e.x array3d.py) from "C:\PROGRAM
FILES\Python24\Lib\site-packages\scipy\weave\examples" I have the following
typical output:



[[[ 0  1  2  3]

  [ 4  5  6  7]

  [ 8  9 10 11]]


 [[12 13 14 15]

  [16 17 18 19]

  [20 21 22 23]]]


Pure Inline:

<weave: compiling>

Found executable C:\MINGW\BIN\g++.exe

g++.exe: C:\program: No such file or directory

g++.exe: files\Python24\lib\site-packages\scipy\weave\scxx\weave_imp.cpp: No
such file or directory

g++.exe: files\python24\lib\site-packages\scipy\weave\scxx\weave_imp.o: No
such file or directory

g++.exe: no input files


And This trace back:


CompileError: error: Command "g++ -mno-cygwin -O2 -Wall -I"C:\program
files\Python24\lib\site-packages\scipy\weave" -I"C:\program
files\Python24\lib\site-packages\scipy\weave\scxx" -I"C:\program
files\Python24\lib\site-packages\numpy\core\include" -I"C:\program
files\Python24\include" -I"C:\program files\Python24\PC" -c C:\program
files\Python24\lib\site-packages\scipy\weave\scxx\weave_imp.cpp -o
files\python24\lib\site-packages\scipy\weave\scxx\weave_imp.o" failed with
exit status 1


IMHO When I put quotes around -c argument  in above command (-c "C:\program
files\Python24\lib\site-packages\scipy\weave\scxx\weave_imp.cpp") every
thing is fine.

Can anyone help me to hack this around?






-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20071229/f3d1c46b/attachment.html 

More information about the SciPy-user mailing list