[SciPy-user] weave and mingw on win xp sp2 bug?

mani sabri mani.sabri@gmail....
Sun Dec 30 03:34:18 CST 2007

>-----Original Message-----
>From: scipy-user-bounces@scipy.org [mailto:scipy-user-bounces@scipy.org] On
>Behalf Of Michael ODonnell
>Sent: Saturday, December 29, 2007 6:04 PM
>To: SciPy Users List
>Hi sorry I did not reply about your inquiry of using weave. It took me
>quite a bit of time to get this to work and I never got any responses.
>Unfortunately, I am heading out the door so I will keep this extremely
>short until I can provide a more complete response tonight or tomorrow
>morning. I was able to get weave inline to work using python 2.5.1 and
>mingw 5.0.3. The path to this needs to be added to your pythonpath variable
>and you need to specify 'gcc' as your compiler. I also worked with VS2003
>and VS2005 Express. And I worked with python 2.4.1 and 2.4.4. None of these
>combinations worked. There was also a problem in numpy with finding the
>python.exe file. I cannot remember if this error was given with VS compiler
>or both VS and MingW.

I managed to run/compile my Time Wrapping function with weave and python
2.4.4 an hour ago. Although the weave.tests continues to show ugly
"Permission Denied" message I had no problem with my func. (and like most
windows users I don't care about that message! Its windows! ;) )

As I remember it is the python24.a file in 2.4.4 that makes the whole
difference because gcc don't know anything about Microsoft lib files.
Anyhow here is a brief state of my system:

- scipy 0.6.0
- numpy 1.0.4
- Python in c:\python24 (no spaces in path! Its important)
- environment variables:
	python_lib = c:\Python24\libs\python24.a
	pythonpath = c:\Python24;C:\PROGRAM FILES\Pyrex-;
	swig_lib =	C:\PROGRAM FILES\swingwin-1.3.27\python
	python_include = C:\Python24\include;

p.s: I saw some posts about cleaning up weave.tests in scipy-dev these days.
I hope they take a look at weave.example directory. 

More information about the SciPy-user mailing list