[SciPy-user] cblas_dtrsm not found

Eric Emsellem emsellem at obs.univ-lyon1.fr
Thu Jan 18 08:52:18 CST 2007


I have been using numpy+scipy+matplotlib extensively in scripts since
quite some time, and regularly updated all these packages using svn.

For some reason the following does not work anymore, and is trying to
find cblas_dtrsm.
I have it in /usr/local/lib/atlas/libcblas.a (I checked doing a "ar -t"
of that library).
I also have that directory in my ld.so.conf (and indeed as ATLAS default

it must be a very stupid mistake I am making here, but I cannot make it
work. (it always worked, and I haven't changed anything in my

(I tried recompiling scipy but no luck)

Anyone has an idea of what is wrong with that?

thanks for any help here.


---> 21 from scipy import optimize, special, interpolate
     22 from scipy.optimize import leastsq, fsolve
     23 from scipy.special import gammainc

      9 from zeros import *
     10 from anneal import *
---> 11 from lbfgsb import fmin_l_bfgs_b
     12 from tnc import fmin_tnc
     13 from cobyla import fmin_cobyla

     29 from numpy import zeros, float64, array, int32
---> 30 import _lbfgsb
     31 import optimize

undefined symbol: cblas_dtrsm

More information about the SciPy-user mailing list