[SciPy-user] cblas_dtrsm not found

Robert Kern robert.kern at gmail.com
Thu Jan 18 10:27:22 CST 2007

Eric Emsellem wrote:
> Hi!
> I have been using numpy+scipy+matplotlib extensively in scripts since
> quite some time, and regularly updated all these packages using svn.
> For some reason the following does not work anymore, and is trying to
> find cblas_dtrsm.
> I have it in /usr/local/lib/atlas/libcblas.a (I checked doing a "ar -t"
> of that library).
> I also have that directory in my ld.so.conf (and indeed as ATLAS default
> dir).
> it must be a very stupid mistake I am making here, but I cannot make it
> work. (it always worked, and I haven't changed anything in my
> ATLAS/BLAS, etc)
> (I tried recompiling scipy but no luck)
> Anyone has an idea of what is wrong with that?

Not without knowing the details of how you built scipy. Can you show us the
output of

  $ python setup.py config


Also, I believe that you can find symbols which are statically linked into the
extension module by using nm(1) (but I'm too lazy to find something that I can
check; I use a shared-library ATLAS on my Linux system).

  $ nm $PYLIB/scipy/optimize/_lbfgsb.so | grep cblas_dtrsm

Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
 that is made terrible by our own mad attempt to interpret it as though it had
 an underlying truth."
  -- Umberto Eco

More information about the SciPy-user mailing list