[SciPy-user] pynetcdf crashing on Python 2.5

Mary Haley haley@ucar....
Wed Jul 18 18:17:14 CDT 2007

Robert, sorry, you're right, this isn't a NumPy issue, but it
manifested itself when I tried to build NumPy. I built Python 2.5 (I
thought successfully), and then when I tried to build NumPy 1.0.3 I
got the error:

    ImportError: No module named _md5

I googled this left and right, and it turns out that when I built
Python 2.5, some module (hashlib?) didn't get built, possibly because
it's expecting some particular version of SSL, and I happen to have a
different version. Python 2.5 is working for me, but I can't build
NumPy because it depends on "_md5" which I believe is dependent
on "hashlib".

I'm still trying to figure thins out. I would be great if I could 
have NumPy bypass this somehow, because I don't think there's
a fix for this on the Python 2.5 end.


On Wed, 18 Jul 2007, Robert Kern wrote:

> Mary Haley wrote:
>> [I haven't gone public with this release yet, because I'm having
>> difficulty trying to build NumPy 1.0.3 on a Linux box that has a newer
>> version of the SSL libraries than what I think NumPy 1.0.3 is
>> expecting.]
> SSL? numpy has nothing to do with SSL.
> -- 
> Robert Kern
> "I have come to believe that the whole world is an enigma, a harmless enigma
> that is made terrible by our own mad attempt to interpret it as though it had
> an underlying truth."
>  -- Umberto Eco
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user

More information about the SciPy-user mailing list