[SciPy-user] missing libacml.so when using cgi script

JJ josh8912@yahoo....
Sun Jul 22 19:16:13 CDT 2007

Hello all:
I am developing a website, initially on my local
machine using the apache httpd server.  My linux box
has scipy/numpy installed, and they work fine from a
terminal.  However, I need to use the programs in a
cgi script and am having problems getting them to
import.  In my bashrc file (for a terminal) I have an
export LD_LIBRARY_PATH statement that leads to my
libacml.so file.  However, when I try to import scipy
from a cgi script I get the following error:

line 30, in ?   import _lbfgsb   ImportError:
libacml.so: cannot open shared object file: No such
file or directory

Numpy does import just fine.  I tried using the
following in the cgi script but it did not correct the

if os.environ.has_key('LD_LIBRARY_PATH')==False:
  os.environ['LD_LIBRARY_PATH'] = path to lib
  os.environ['LD_LIBRARY_PATH'] =
os.environ['LD_LIBRARY_PATH'] + path to lib

I also tried adding similar statments for LD_RUN_PATH
and LAPACK to no avail.  Also, file permissions for
the folder with libacml.so are set to allow others to
read.  Does anyone know how I might get scipy working
from a cgi script?


Take the Internet to Go: Yahoo!Go puts the Internet in your pocket: mail, news, photos & more. 

More information about the SciPy-user mailing list