[SciPy-user] missing libacml.so when using cgi script

JJ josh8912@yahoo....
Tue Jul 24 16:28:28 CDT 2007

Robert Kern <robert.kern <at> gmail.com> writes:

> This won't work. The LD_LIBRARY_PATH environment variable needs to be set
> the process starts, not just before the library is loaded. Read the Apache
> documentation for how to set up the environment for your CGI scripts.

Thanks Robert:
I have now tried using the SetEnv directive, as Apache instructs.  I added the
following to the end of the httpd.config file
SetEnv LD_LIBRARY_PATH /home/john/usr/acml/gnu64/lib
SetEnv LAPACK /home/john/usr/acml/gnu64/lib/libacml.so
SetEnv LD_RUN_PATH /home/john/usr/acml/gnu64/lib

When I run my cgi script, I can verify that indeed these environment vaiables
have been set.  But the cgi script still fails when I try to import scipy,
giving the message that libacml.so cannot be found.  This is odd, as I can
import scipy just fine in a terminal window.  Any ideas?  I have written to the
Apache list also.

More information about the SciPy-user mailing list