[SciPy-user] Plea: Installing SciPy on Mac 10.4.9: _fftpack.so problems?

Lawrence David ldavid@MIT....
Thu Mar 15 11:36:59 CDT 2007

Hi there,

I'm pulling the little hair I have out trying to install SciPy on my  
G4 PPC running OS 10.4.9.

I've followed the instructions on the SciPy.org website: http:// 
www.scipy.org/Installing_SciPy/Mac_OS_X.  I've got gcc 4.0.1 and  
gfortran (gnu95 -> 4.3).

Running build: "python setup.py build_src build_clib -- 
fcompiler=gnu95 build_ext --fcompiler=gnu95 build", yields a long  
error message that terminates with a litany of "Undefined symbols"  
and this last message:

collect2: ld returned 1 exit status
error: Command "/usr/local/bin/gfortran -L/sw/lib build/ 
_fftpackmodule.o build/temp.macosx-10.3-fat-2.5/Lib/fftpack/src/ 
zfft.o build/temp.macosx-10.3-fat-2.5/Lib/fftpack/src/drfft.o build/ 
temp.macosx-10.3-fat-2.5/Lib/fftpack/src/zrfft.o build/ 
temp.macosx-10.3-fat-2.5/Lib/fftpack/src/zfftnd.o build/ 
fortranobject.o -L/usr/local/lib -L/usr/local/lib/gcc/powerpc-apple- 
darwin8.8.0/4.3.0 -Lbuild/temp.macosx-10.3-fat-2.5 -ldfftpack -lfftw3  
-lgfortran -o build/lib.macosx-10.3-fat-2.5/scipy/fftpack/ 
_fftpack.so" failed with exit status 1

I've noticed several other folks have had similar error messages on  
this board, but none of the posted solutions worked for me.  If  
anyone could offer any suggestions on what to try, I'd love to hear  

(I've even tried installing the SuperPack binary, which lies through  
its teeth when it says that it's installed correctly; import scipy  
still fails.  Perhaps my problem is that I'm using gfortran?  Can  
anyone tell me how to revert to g77?)

Much thanks!!
- lawrence


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20070315/1a4b50b5/attachment.html 

More information about the SciPy-user mailing list