[SciPy-user] building numpy/scipy on Solaris

raphael langella raphael.langella@steria....
Tue Mar 20 06:08:14 CDT 2007

I'm trying to build numpy and scipy on Solaris 8.
The BLAS FAQ on netlib.org suggests using optimized BLAS librairies
provided by computer vendor, like the SUN Performance Library. This
library is supposed to provide enhanced and optimized version of BLAS
and LAPACK. I happen to have Forte 7 installed, so I first tried to
build against this library (libsunperf.a).
I tried several versions and different compilation options, but I always
get undefined symbols. Is this supported? As anyone ever succeeded in
using this library to compile scipy and numpy?
I also did some unsuccessful tests with Atlas. But, I think I'm now very
close to have it working with the standard BLAS/LAPACK (from
netlib.org). I have to use GNU ld (unresolved symbols when using Sun's
ld). Numpy builds and tests without any error. I've got a few errors and
failures with scipy (see attachment for the complete test report). Are
these errors critical? I don't understand where they come from and how
to correct them.
Thanks for your help.

Raphaël Langella
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: scipy.test.txt
Url: http://projects.scipy.org/pipermail/scipy-user/attachments/20070320/7dbb4363/attachment-0001.txt 

More information about the SciPy-user mailing list