[SciPy-user] building numpy/scipy on Solaris

raphael langella raphael.langella@steria....
Wed Mar 21 03:59:04 CDT 2007

---- Messages d´origine ----
De: "David M. Cooke" <cookedm@physics.mcmaster.ca>
Date: mardi, mars 20, 2007 6:56 pm
Objet: Re: [SciPy-user] building numpy/scipy on Solaris

> On Tue, Mar 20, 2007 at 12:08:14PM +0100, raphael langella wrote:
> > I'm trying to build numpy and scipy on Solaris 8.
> > The BLAS FAQ on netlib.org suggests using optimized BLAS librairies
> > provided by computer vendor, like the SUN Performance Library. This
> > library is supposed to provide enhanced and optimized version of 
> BLAS> and LAPACK. I happen to have Forte 7 installed, so I first 
> tried to
> > build against this library (libsunperf.a).
> > I tried several versions and different compilation options, but I 
> always> get undefined symbols. Is this supported? As anyone ever 
> succeeded in
> > using this library to compile scipy and numpy?
> Haven't heard about anybody else trying it. What are the undefined
> symbols? One thing I can think of that I've run into before on a Alpha
> was that the Compaq Math Library only had LAPACK version 2, not 
> version3 (which had been already been out for several years when 
> our group got
> the Alpha...).

It's supposed to support LAPACK v3.0 and BLAS1, 2 & 3
It gives me this when I import numpy :
ImportError: ld.so.1: python: fatal: relocation error: file
/usr/lib/python2.3/site-packages/numpy/linalg/lapack_lite.so: symbol
__getenv_: referenced symbol not found

> > /home/user1/ctcils/poladmin/rla/root/lib/python2.3/site-
> packages/scipy/linsolve/umfpack/tests/test_umfpack.py:17:
AttributeError: 'module' object has no attribute 'umfpack' (in ?)
> UMFPACK not built?

right. I'm not sure if my users will need it, but I'll try building it

> > Warning: FAILURE importing tests for <module 
> 'scipy.optimize.zeros' from '...kages/scipy/optimize/zeros.pyc'>
> > /home/user1/ctcils/poladmin/rla/root/lib/python2.3/site-
> packages/scipy/optimize/lbfgsb.py:30: ImportError: ld.so.1: python: 
> fatal: relocation error: file 
symbol etime_: referenced symbol not found (in ?)
> This one looks like the Sun Fortran compiler doesn't have etime. Not
> serious unless you use optimize.fmin_l_bfgs_b.

Well, let's say it's not critical for now...
> > Warning: FAILURE importing tests for <module 'scipy.io.mio' from 
> '...site-packages/scipy/io/mio.pyc'>
> > /home/user1/ctcils/poladmin/rla/root/lib/python2.3/site-
> packages/scipy/io/tests/test_mio.py:14: ImportError: cannot import 
> name loadmat (in ?)
> Odd. loadmat comes from scipy.io.mio, and it's a pure python routine.
> Did you remove the build/ directory before trying again? Distutils can
> get confused if it's interrupted (it doesn't do dependency tracking 
> thatwell).

Yes I did.
> > NameError: global name 'sorted' is not defined
> Fixed in svn; a 2.4ism snuck in.

I'll try it.

> Huh, I'd say the Sun library isn't accurate enough. Sacrificing 
> accuracyfor speed, no doubt.

OK, but I didn't compile scipy and numpy against libsunperf, I used
netlib.org versions of blas and lapack. On the other hand, I did build
lapack against libsunperf (that's the default in make.inc.SUN4SOL2), so
I'm not sure which blas library is used in the end.

Thanks a lot for your support

More information about the SciPy-user mailing list