[SciPy-user] building numpy/scipy on Solaris

raphael langella raphael.langella@steria....
Thu Mar 29 07:03:45 CDT 2007

I just realized I've got much more recent versions of libsunperf and C
and fortran compilers. I've got Sun Studio 10 & 11 installed. So I tried
building numpy with both of them and each time I get this error when
importing numpy :

>>> import numpy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/tmp/lib/python2.5/site-packages/numpy/__init__.py", line 40, in
    import linalg
  File "/tmp/lib/python2.5/site-packages/numpy/linalg/__init__.py", line
4, in <module>
    from linalg import *
  File "/tmp/lib/python2.5/site-packages/numpy/linalg/linalg.py", line
25, in <module>
    from numpy.linalg import lapack_lite
ImportError: ld.so.1: python: fatal: relocation error: file
/tmp/lib/python2.5/site-packages/numpy/linalg/lapack_lite.so: symbol
__mt_MasterFunction_rtc_: referenced symbol not found

I tried the CPPFLAGS='-DNO_APPEND_FORTRAN' option, but it didn't change
anything. Any idea?

-------------- next part --------------
SciPy-user mailing list

More information about the SciPy-user mailing list