[SciPy-user] fortran compiler not found Mac Leopard 10.5

Brian Granger ellisonbg.net@gmail....
Mon Nov 12 12:39:04 CST 2007

Are you using the builtin python?
Are you using the numpy that comes with the builtin python?

If so, you will need to upgrade numpy first.  But, there are some
pitfalls along this path as well.  See recent threads on the numpy
list and the pythonmac-sig list for details.  Or, just use the python
binary from python.org and install numpy/scipy from scratch.


On Nov 12, 2007 10:06 AM, Jeremy Conlin <jeremit0@gmail.com> wrote:
> Hello all.  I recently upgraded scipy from the svn distribution and
> tried installing it.  I followed the instructions on
> http://scipy.org/Installing_SciPy/Mac_OS_X
> and downloaded the gfortran binaries from the att.com site.  When I run
> python setup.py build
> it compiles for awhile but fails.  The last few messages are copied at
> the end of this message.  Is another compiler (i.e. f95) needed?  Do I
> just need to rename the gfortran executable?  I tried making a symlink
>  g95->gfortran but it didn't work.  Does anyone have any suggestions?
> Thanks,
> Jeremy
> $ gcc --version
> i686-apple-darwin9-gcc-4.0.1 (GCC) 4.0.1 (Apple Inc. build 5465)
> Copyright (C) 2005 Free Software Foundation, Inc.
> This is free software; see the source for copying conditions.  There is NO
> $ gfortran --version
> GNU Fortran (GCC) 4.2.1
> Copyright (C) 2007 Free Software Foundation, Inc.
> GNU Fortran comes with NO WARRANTY, to the extent permitted by law.
> You may redistribute copies of GNU Fortran
> under the terms of the GNU General Public License.
> For more information about these matters, see the file named COPYING
> $ python setup.py build
>> compiling Fortran sources
> Fortran f77 compiler: f95 -fixed -O4 -target=native
> Fortran f90 compiler: f95 -O4 -target=native
> Fortran fix compiler: f95 -fixed -O4 -target=native
> creating build/temp.macosx-10.5-i386-2.5
> creating build/temp.macosx-10.5-i386-2.5/scipy
> creating build/temp.macosx-10.5-i386-2.5/scipy/fftpack
> creating build/temp.macosx-10.5-i386-2.5/scipy/fftpack/dfftpack
> compile options: '-c'
> f95:f77: scipy/fftpack/dfftpack/dcosqb.f
> sh: f95: command not found
> sh: f95: command not found
> error: Command "f95 -fixed -O4 -target=native -c -c
> scipy/fftpack/dfftpack/dcosqb.f -o
> build/temp.macosx-10.5-i386-2.5/scipy/fftpack/dfftpack/dcosqb.o"
> failed with exit status 127
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user

More information about the SciPy-user mailing list