[SciPy-user] bvp

Pauli Virtanen pav@iki...
Tue Apr 15 02:34:24 CDT 2008

Mon, 14 Apr 2008 22:15:01 -0700, Agile Aspect wrote:
> Hi - I tried version 0.2.2 using Python 2.4.2 from the command line and
> it works great!
> I have a related question which may be off topic.
> When I run this test script from inside Eclipse using Python/Qt4 (the
> same C based Python I used to test bvp from the command line) it
> generates the following error
>                 Traceback (most recent call last):
>                  File
> "/home/ken/projects/workspace/cpp/bvp/src/test/ex1.py", line 24, in ?
>                  solution = bvp.colnew.solve(
>                 AttributeError: 'module' object has no attribute
>                 'colnew'
> Any ideas as to what might be causing this problem?
> Is this permission problem? Would it be possible to use reflection to
> get around it?

This is strange. Does

	import bvp.colnew

work inside eclipse? Are you running Eclipse in the bvp source directory 
(will not work, because the bvp directory in the source package doesn't 
contain the compiled extensions). Is your Python path correctly set in 

Pauli Virtanen

More information about the SciPy-user mailing list