[SciPy-user] Help with Scientific's NetCDF[SEC=UNCLASSIFIED]

Scott Collis s.collis@bom.gov...
Wed Apr 23 18:43:48 CDT 2008

Ok, I know this is not strictly SciPy, being from the Scientific
Branch... But I was hoping some one might know...

I have been able to get the Scientific.IO.NetCDF library working on
other machines but trying to install it, as a user (no root access...)
on a cluster machine here I get the following error:
>>> import Scientific.IO.NetCDF
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
"/flurry/home/scollis/pylibs/lib64/python2.4/site-packages/Scientific/IO/NetCDF.py", line 165, in ?
    from Scientific_netcdf import *
ImportError: libnetcdf.so.4: cannot open shared object file: No such
file or directory

now I have found where libnetcdf.so.4 is located and I have added that
to sys.path {sys.path.append("/usr/local/netcdf-3.6.2a/lib/")} I have
tried assing said directory to PYTHONPATH (export

It just does not seem to want ot find the NetCDF library... I have not
really tried the scipy NetCDF library... I am used to the way the
Scientific one works.... 

I have had a look though some of the source (Scientific_netcdf.c) and
can not obviously see where it specifically points to the libs...
Any Help appreciated...


More information about the SciPy-user mailing list