[SciPy-user] Python on Intel Xeon Dual Core Machine

David Cournapeau david@ar.media.kyoto-u.ac...
Fri Feb 8 00:39:48 CST 2008

Nathan Bell wrote:
> On Feb 6, 2008 12:58 PM, william ratcliff <william.ratcliff@gmail.com> wrote:
>> Has anyone played with openmp using ctypes or weave?
> Just FYI I tried some openmp code with gcc 4.2 and found that I
> couldn't load the module dynamically.  Here's a similar report:
> http://newsgroups.derkeiler.com/Archive/Comp/comp.soft-sys.matlab/2008-01/msg00893.html
> This was using SWIG, but I think you'd encounter the same problem with
> ctypes or weave.  It's a known bug that should be fixed in a future
> release.
FWIW, I could dynamically load a trivial openmp shared library through 
the dlopen machinery, which is what ctypes uses (to be exact, all python 
extensions which are not static use it at some point). I tried with 
centos 5.0 gcc, and then with one directly built from sources (4.2.1), 
both with success.

Which compiler (version of gcc) are you using ? Do you have the code 
which fails ?



More information about the SciPy-user mailing list