[SciPy-user] ImportError: No module named multiarray

Gerolf Ziegenhain ziegen@rhrk.uni-kl...
Fri Feb 15 13:42:31 CST 2008

Hi scipy-group,

Today I tried to compile scipy/numpy on my own, because the Debian/Etch
versions don't contain the delaunay and fitting stuff. Following some hints
in the web I installed umfpack and adjusted the site.cfg for numpy. Then I
removed the original Debian packages in order to have a clean setup. Then I
compiled and installed numpy. This was working without any error message.
When I tried to compile scipy afterwards I realized the failure: somehow
multiarray is not accessible.

What can I do now? I didn't find any useful hint in the web so far...

setup.py (scipy) says:
Writing /usr/lib/python2.4/site-packages/numpy-1.0.4.egg-info
Traceback (most recent call last):
  File "./setup.py", line 55, in ?
  File "./setup.py", line 28, in setup_package
    from numpy.distutils.core import setup
  File "/usr/lib/python2.4/site-packages/PIL/__init__.py", line 39, in ?
  File "/usr/lib/python2.4/site-packages/PIL/__init__.py", line 5, in ?
    # package placeholder
ImportError: No module named multiarray

ipython replies to import numpy:
ImportError                               Traceback (most recent call last)
/home/gerolf/src/python/<ipython console>
ImportError: No module named multiarray

Best regards:

Dipl. Phys. Gerolf Ziegenhain
Office: Room 46-332 - Erwin-Schrödinger-Str.46 - TU Kaiserslautern - Germany
Web: gerolf.ziegenhain.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20080215/00b51369/attachment.html 

More information about the SciPy-user mailing list