[SciPy-user] scipy-0.6 on AIX 5.3

david cournape@gmail....
Tue Jul 15 16:43:04 CDT 2008

Marek Wojciechowski <mwojc <at> p.lodz.pl> writes:

> IBM Fortran compiler (xlf) worked very well for me.

Well, it does not work here.

> The only compilation
> problem is with two functions in specfun.f, namely: CLQN and CLQMN.
> However, this is because of the aggressive -O5 optimization flag (which is
> set up by default on AIX in numpy.distutils). With -O3 whole code compiles
> nicely.

That's strange, since the errors are syntax related. In particular, from your
 output, it seemed like some comments were causing problems.

> BTW. i'm not sure if there is a way to get working g77 or gfortran on AIX.

Yes. When I googled for your problem on AIX, I saw similar problems 
compiling octave, and using gnu fortran compilers did solve the problem.

But anyway, since changing the optimization level worked, I guess there is no 
need for that anymore.



More information about the SciPy-user mailing list