[SciPy-user] Test failure on OS X Leopard

Neil Martinsen-Burrell nmb@wartburg....
Mon Jun 23 12:32:26 CDT 2008

David Cournapeau <david <at> ar.media.kyoto-u.ac.jp> writes:

> AndresGM wrote:
> >
> > ImportError: Need nose >=0.10 for tests - see
> >   
> What about installing nose :) Starting from 0.7 for scipy and 1.2 for
> numpy (meaning svn trunk as well for both packages), nose is a hard
> dependency.

To be crystal-clear, nose is *not* a dependency for running anything in scipy or
numpy, nor will this ever be the case.  It *is* a hard dependency for running
the numpy and scipy test suites as of the current SVN versions of both scipy and
numpy.  (Scipy made the change before numpy but they will eventually converge in
the next releases.)


More information about the SciPy-user mailing list