[SciPy-user] Installing on Ubuntu with mkl 10.0.2: libimf.so not found

Matthieu Brucher matthieu.brucher@gmail....
Tue Nov 4 08:54:35 CST 2008

> That worked! So I can install scipy, but for packages that have binaries
> like PyTables I still need root permissions. How can I make the library
> available when I use sudo?
> Thanks,
> Anand

Well, it should have worked with the sudo :|
Is it an installation for all users or just for you ? If it is the
latter, I suggest you to create a local folder in your home directory
where you will put everything (every decent installation tool has the
--prefix options which will correctly populate the local folder, you
just have to set the environment variables correctly, but you already
modified LD_LIBRARY_PATH, it won't much more trouble). This way, you
don't need root permission and you won't mess up with the system
installation. This is what I did on every computer even where I had
sudo capabilities. Less trouble in the long run ;)

Information System Engineer, Ph.D.
Website: http://matthieu-brucher.developpez.com/
Blogs: http://matt.eifelle.com and http://blog.developpez.com/?blog=92
LinkedIn: http://www.linkedin.com/in/matthieubrucher

More information about the SciPy-user mailing list