[SciPy-user] Installing on Ubuntu with mkl 10.0.2: libimf.so not found

Anand Patil anand.prabhakar.patil@gmail....
Tue Nov 4 09:06:21 CST 2008

On Tue, Nov 4, 2008 at 2:54 PM, Matthieu Brucher <matthieu.brucher@gmail.com
> wrote:

> > That worked! So I can install scipy, but for packages that have binaries
> > like PyTables I still need root permissions. How can I make the library
> > available when I use sudo?
> > Thanks,
> > Anand
> Well, it should have worked with the sudo :|
> Is it an installation for all users or just for you ? If it is the
> latter, I suggest you to create a local folder in your home directory
> where you will put everything (every decent installation tool has the
> --prefix options which will correctly populate the local folder, you
> just have to set the environment variables correctly, but you already
> modified LD_LIBRARY_PATH, it won't much more trouble). This way, you
> don't need root permission and you won't mess up with the system
> installation. This is what I did on every computer even where I had
> sudo capabilities. Less trouble in the long run ;)

Will do... that's really weird, but I'm glad to have my Python environment
up and running anyway!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20081104/910435b9/attachment.html 

More information about the SciPy-user mailing list