[SciPy-user] Installation from source on OS X: 'NoneType' object has no attribute 'link_shared_object'

David Hsu dhsu2@u.washington....
Fri Oct 3 16:27:53 CDT 2008

Michael Williams <williams <at> astro.ox.ac.uk> writes:

> On 27 Sep 2008, at 00:14, Robert Kern wrote:
> > I very much recommend against using the binaries from HPC. They
> > release binaries for buggy bleeding-edge versions of gfortran, and
> > don't keep previous versions around.
> Thanks for the heads-up. I'm not experienced with Fortran.
> > I have had *much* more luck with
> > the binaries over here:
> >
> >  http://r.research.att.com/tools/
> >
> > Since you don't have admin privileges, you need to do a little command
> > line work instead of just being able to use the installer. Mount
> > gfortran-4.2.3.dmg. At the terminal:
> That procedure to install the compiler worked fine, and scipy itself  
> seems to have built cleanly using it.
> Thanks very much!

Hi, I'm having the exact same problem and error message, but for some reason I
can't get past this step.  I've tried the suggestions here:


At the step where it requires building the fftw library, I get:

DRIVE:fftw-3.1.2 dhsu$ make
make  all-recursive
Making all in support
make[2]: *** No rule to make target `all'.  Stop.
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

and "sudo make install" has the same result.  Then, when I go to build SciPy
itself, I get almost the exact same errors as in the thread above.  What am I
doing wrong?




MacBook Pro Core Duo
Python 2.5.1
Numpy 1.0.4
SciPy 0.6.0
GNU Fortran 4.2.3 (as suggested)

More information about the SciPy-user mailing list