[SciPy-User] troubles installing scipy (swing)

David Cournapeau david@ar.media.kyoto-u.ac...
Thu Aug 6 22:30:25 CDT 2009


Lucia wrote:
> Hello,
> I am not an expert, and I am desperate, so please help me!
> I am trying to install numpy and scipy on my Mac (OS X Version
> 10.5.7), following the instructions I found here:
> http://www.scipy.org/Installing_SciPy/Mac_OS_X (using SVN).
>   

Is there a reason why you don't use the binary installers ? They won't
work with the fink/macport python, but you won't have to worry about any
building problems: install the python from python.org, and then numpy
and scipy. You need numpy 1.3.0 and scipy 0.7.1 for python 2.6:

http://sourceforge.net/projects/numpy/files/NumPy/
http://sourceforge.net/projects/scipy/files/

> swig: scipy/sparse/linalg/dsolve/umfpack/umfpack.i
> swig -python -o
> build/src.macosx-10.5-i386-2.6/scipy/sparse/linalg/dsolve/umfpack/_umfpack_wrap.c
> -outdir build/src.macosx-10.5-i386-2.6/scipy/sparse/linalg/dsolve/umfpack
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:192: Error: Unable to
> find 'umfpack.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:193: Error: Unable to
> find 'umfpack_solve.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:194: Error: Unable to
> find 'umfpack_defaults.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:195: Error: Unable to
> find 'umfpack_triplet_to_col.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:196: Error: Unable to
> find 'umfpack_col_to_triplet.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:197: Error: Unable to
> find 'umfpack_transpose.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:198: Error: Unable to
> find 'umfpack_scale.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:200: Error: Unable to
> find 'umfpack_report_symbolic.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:201: Error: Unable to
> find 'umfpack_report_numeric.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:202: Error: Unable to
> find 'umfpack_report_info.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:203: Error: Unable to
> find 'umfpack_report_control.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:215: Error: Unable to
> find 'umfpack_symbolic.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:216: Error: Unable to
> find 'umfpack_numeric.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:225: Error: Unable to
> find 'umfpack_free_symbolic.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:226: Error: Unable to
> find 'umfpack_free_numeric.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:248: Error: Unable to
> find 'umfpack_get_lunz.h'
> scipy/sparse/linalg/dsolve/umfpack/umfpack.i:272: Error: Unable to
> find 'umfpack_get_numeric.h'
> error: command 'swig' failed with exit status 1
>   

You could try UMFPACK=None python setup.py build. But really, installing
the binaries is easier.

cheers,

David


More information about the SciPy-User mailing list