[SciPy-User] errors from scipy.test(), from import calc_lwork

robert roze rbroze@yahoo....
Wed Aug 26 18:14:20 CDT 2009


I get 10 errors from the scipy.test() routine. Nine of them appear to happen when the linalg/basic.py module executes: 

from scipy.linalg import calc_lwork
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/net/easystreet/vol/homes/rroze/Python-2.6.2/lib/python2.6/site-packages/scipy/linalg/__init__.py", line 8, in <module>
    from basic import *
  File "/net/easystreet/vol/homes/rroze/Python-2.6.2/lib/python2.6/site-packages/scipy/linalg/basic.py", line 24, in <module>
    from scipy.linalg import calc_lwork
ImportError: cannot import name calc_lwork

It seems like all modules that import calc_lwork fail this way. At the python command line, I get the ImportError from all these modules:
 scipy.stats, scipy.signal, scipy.maxentropy, scipy.linalg, scipy.interpolate
All, complaining about "calc_lwork"

But the other modules import without complaint (scipy.sparse, scipy.optimize, etc...)

In
the site-packages/scipy/linalg directory, there is a file called
calc_lwork.so, so it appears to exist, but it is a binary file, I don't
know the type, why it wouldn't be import-able, and this is where my software skills start to fade. Does anyone have any idea why calc_lwork can't import?

Here is the info on my platform, versions, etc:

1) Platform information::
  posix linux2
  Linux ld23 2.6.9-78.0.5.ELsmp #1 SMP Wed Sep 24 05:40:24 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
  RedHad Enterprise version 3.4, and I do not have root

2) Information about C,C++,Fortran compilers/linkers as reported by
   the compilers when requesting their version information, e.g.,
   the output of
   ::
gcc -v
Reading specs from /usr/lib/gcc/x86_64-redhat-linux/3.4.6/specs
Configured
with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-java-awt=gtk
--host=x86_64-redhat-linux
Thread model: posix
gcc version 3.4.6 20060404 (Red Hat 3.4.6-8)

g77 --version
GNU Fortran (GCC) 3.4.6 20060404 (Red Hat 3.4.6-8)
Copyright (C) 2006 Free Software Foundation, Inc.

3) Python version::
python -c 'import sys;print sys.version'
2.6.2 (r262:71600, Aug 26 2009, 13:45:43)
[GCC 3.4.6 20060404 (Red Hat 3.4.6-8)]

4) NumPy version::
python -c 'import numpy;print numpy.__version__'
1.3.0

5) ATLAS version, the locations of atlas and lapack libraries, building
   information if any. If you have ATLAS version 3.3.6 or newer, then
   give the output of the last command in
   ::
     cd scipy/Lib/linalg

  I didn't find this directory, but found a similar one here:

scipy-0.7.1/scipy/linalg

  which contained the file, setup_atlas_version.py, so I ran it and got this error:

python setup_atlas_version.py build_ext --inplace --force
Traceback (most recent call last):
  File "setup_atlas_version.py", line 7, in <module>
    from numpy.distutils.misc_util import get_path, default_config_dict
ImportError: cannot import name get_path

python -c 'import atlas_version'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named atlas_version

7)  The output of the following commands

python /net/easystreet/vol/homes/rroze/Python-2.6.2/lib/python2.6/site-packages/numpy/distutils/system_info.py
lapack_info:
  libraries lapack not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries lapack not found in /usr/local/lib64
  libraries lapack not found in /usr/local/lib
  FOUND:
    libraries = ['lapack']
    library_dirs = ['/usr/lib64']
    language = f77

lapack_opt_info:
lapack_mkl_info:
mkl_info:
  libraries mkl,vml,guide not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries mkl,vml,guide not found in /usr/local/lib64
  libraries mkl,vml,guide not found in /usr/local/lib
  libraries mkl,vml,guide not found in /usr/lib64
  libraries mkl,vml,guide not found in /usr/lib
  NOT AVAILABLE

  NOT AVAILABLE

atlas_threads_info:
Setting PTATLAS=ATLAS
  libraries ptf77blas,ptcblas,atlas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries lapack_atlas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib64
  libraries lapack_atlas not found in /usr/local/lib64
  libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib
  libraries lapack_atlas not found in /usr/local/lib
  libraries ptf77blas,ptcblas,atlas not found in /usr/lib64
  libraries lapack_atlas not found in /usr/lib64
  libraries ptf77blas,ptcblas,atlas not found in /usr/lib/sse2
  libraries lapack_atlas not found in /usr/lib/sse2
  libraries ptf77blas,ptcblas,atlas not found in /usr/lib
  libraries lapack_atlas not found in /usr/lib
__main__.atlas_threads_info
  NOT AVAILABLE

atlas_info:
  libraries f77blas,cblas,atlas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries lapack_atlas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries f77blas,cblas,atlas not found in /usr/local/lib64
  libraries lapack_atlas not found in /usr/local/lib64
  libraries f77blas,cblas,atlas not found in /usr/local/lib
  libraries lapack_atlas not found in /usr/local/lib
  libraries f77blas,cblas,atlas not found in /usr/lib64
  libraries lapack_atlas not found in /usr/lib64
  libraries f77blas,cblas,atlas not found in /usr/lib/sse2
  libraries lapack_atlas not found in /usr/lib/sse2
  libraries f77blas,cblas,atlas not found in /usr/lib
  libraries lapack_atlas not found in /usr/lib
__main__.atlas_info
  NOT AVAILABLE

/net/easystreet/vol/homes/rroze/Python-2.6.2/lib/python2.6/site-packages/numpy/distutils/system_info.py:1290: UserWarning:
    Atlas (http://math-atlas.sourceforge.net/) libraries not found.
    Directories to search for the libraries can be specified in the
    numpy/distutils/site.cfg file (section [atlas]) or by setting
    the ATLAS environment variable.
  warnings.warn(AtlasNotFoundError.__doc__)
blas_info:
  libraries blas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries blas not found in /usr/local/lib64
  libraries blas not found in /usr/local/lib
  FOUND:
    libraries = ['blas']
    library_dirs = ['/usr/lib64']
    language = f77

  FOUND:
    libraries = ['lapack', 'blas']
    library_dirs = ['/usr/lib64']
    define_macros = [('NO_ATLAS_INFO', 1)]
    language = f77

wx_info:
Could not locate executable wx-config
File not found: None. Cannot determine wx info.
  NOT AVAILABLE

lapack_atlas_info:
  libraries lapack_atlas,f77blas,cblas,atlas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries lapack_atlas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries lapack_atlas,f77blas,cblas,atlas not found in /usr/local/lib64
  libraries lapack_atlas not found in /usr/local/lib64
  libraries lapack_atlas,f77blas,cblas,atlas not found in /usr/local/lib
  libraries lapack_atlas not found in /usr/local/lib
  libraries lapack_atlas,f77blas,cblas,atlas not found in /usr/lib64
  libraries lapack_atlas not found in /usr/lib64
  libraries lapack_atlas,f77blas,cblas,atlas not found in /usr/lib/sse2
  libraries lapack_atlas not found in /usr/lib/sse2
  libraries lapack_atlas,f77blas,cblas,atlas not found in /usr/lib
  libraries lapack_atlas not found in /usr/lib
__main__.lapack_atlas_info
  NOT AVAILABLE

umfpack_info:
  libraries umfpack not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries umfpack not found in /usr/local/lib64
  libraries umfpack not found in /usr/local/lib
  libraries umfpack not found in /usr/lib64
  libraries umfpack not found in /usr/lib
  NOT AVAILABLE

_pkg_config_info:
Found executable /usr/bin/pkg-config
  NOT AVAILABLE

lapack_atlas_threads_info:
Setting PTATLAS=ATLAS
  libraries lapack_atlas,ptf77blas,ptcblas,atlas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries lapack_atlas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries lapack_atlas,ptf77blas,ptcblas,atlas not found in /usr/local/lib64
  libraries lapack_atlas not found in /usr/local/lib64
  libraries lapack_atlas,ptf77blas,ptcblas,atlas not found in /usr/local/lib
  libraries lapack_atlas not found in /usr/local/lib
  libraries lapack_atlas,ptf77blas,ptcblas,atlas not found in /usr/lib64
  libraries lapack_atlas not found in /usr/lib64
  libraries lapack_atlas,ptf77blas,ptcblas,atlas not found in /usr/lib/sse2
  libraries lapack_atlas not found in /usr/lib/sse2
  libraries lapack_atlas,ptf77blas,ptcblas,atlas not found in /usr/lib
  libraries lapack_atlas not found in /usr/lib
__main__.lapack_atlas_threads_info
  NOT AVAILABLE

x11_info:
  FOUND:
    libraries = ['X11']
    library_dirs = ['/usr/X11R6/lib64']
    include_dirs = ['/usr/X11R6/include']

fftw_info:
  libraries fftw3 not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries fftw3 not found in /usr/local/lib64
  libraries fftw3 not found in /usr/local/lib
  libraries fftw3 not found in /usr/lib64
  libraries fftw3 not found in /usr/lib
  fftw3 not found
  libraries rfftw,fftw not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries rfftw,fftw not found in /usr/local/lib64
  libraries rfftw,fftw not found in /usr/local/lib
  libraries rfftw,fftw not found in /usr/lib64
  libraries rfftw,fftw not found in /usr/lib
  fftw2 not found
  NOT AVAILABLE

f2py_info:
  FOUND:
    sources = ['/net/easystreet/vol/homes/rroze/Python-2.6.2/lib/python2.6/site-packages/numpy/f2py/src/fortranobject.c']
    include_dirs = ['/net/easystreet/vol/homes/rroze/Python-2.6.2/lib/python2.6/site-packages/numpy/f2py/src']

gdk_pixbuf_xlib_2_info:
  NOT AVAILABLE

dfftw_threads_info:
  libraries drfftw_threads,dfftw_threads not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries drfftw_threads,dfftw_threads not found in /usr/local/lib64
  libraries drfftw_threads,dfftw_threads not found in /usr/local/lib
  libraries drfftw_threads,dfftw_threads not found in /usr/lib64
  libraries drfftw_threads,dfftw_threads not found in /usr/lib
  dfftw threads not found
  NOT AVAILABLE

atlas_blas_info:
  libraries f77blas,cblas,atlas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries f77blas,cblas,atlas not found in /usr/local/lib64
  libraries f77blas,cblas,atlas not found in /usr/local/lib
  libraries f77blas,cblas,atlas not found in /usr/lib64
  libraries f77blas,cblas,atlas not found in /usr/lib/sse2
  libraries f77blas,cblas,atlas not found in /usr/lib
  NOT AVAILABLE

fftw3_info:
  libraries fftw3 not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries fftw3 not found in /usr/local/lib64
  libraries fftw3 not found in /usr/local/lib
  libraries fftw3 not found in /usr/lib64
  libraries fftw3 not found in /usr/lib
  fftw3 not found
  NOT AVAILABLE

blas_opt_info:
blas_mkl_info:
  libraries mkl,vml,guide not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries mkl,vml,guide not found in /usr/local/lib64
  libraries mkl,vml,guide not found in /usr/local/lib
  libraries mkl,vml,guide not found in /usr/lib64
  libraries mkl,vml,guide not found in /usr/lib
  NOT AVAILABLE

atlas_blas_threads_info:
Setting PTATLAS=ATLAS
  libraries ptf77blas,ptcblas,atlas not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib64
  libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib
  libraries ptf77blas,ptcblas,atlas not found in /usr/lib64
  libraries ptf77blas,ptcblas,atlas not found in /usr/lib/sse2
  libraries ptf77blas,ptcblas,atlas not found in /usr/lib
  NOT AVAILABLE

/net/easystreet/vol/homes/rroze/Python-2.6.2/lib/python2.6/site-packages/numpy/distutils/system_info.py:1383: UserWarning:
    Atlas (http://math-atlas.sourceforge.net/) libraries not found.
    Directories to search for the libraries can be specified in the
    numpy/distutils/site.cfg file (section [atlas]) or by setting
    the ATLAS environment variable.
  warnings.warn(AtlasNotFoundError.__doc__)
  FOUND:
    libraries = ['blas']
    library_dirs = ['/usr/lib64']
    define_macros = [('NO_ATLAS_INFO', 1)]
    language = f77

sfftw_info:
  libraries srfftw,sfftw not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries srfftw,sfftw not found in /usr/local/lib64
  libraries srfftw,sfftw not found in /usr/local/lib
  libraries srfftw,sfftw not found in /usr/lib64
  libraries srfftw,sfftw not found in /usr/lib
  sfftw not found
  NOT AVAILABLE

xft_info:
  FOUND:
    libraries = ['Xft', 'X11', 'freetype', 'Xrender', 'fontconfig']
    library_dirs = ['/usr/X11R6/lib64']
    define_macros = [('XFT_INFO', '"\\"2.1.2.2\\""'), ('XFT_VERSION_2_1_2_2', None)]
    include_dirs = ['/usr/X11R6/include', '/usr/include/freetype2', '/usr/include/freetype2/config']

fft_opt_info:
fftw2_info:
  libraries rfftw,fftw not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries rfftw,fftw not found in /usr/local/lib64
  libraries rfftw,fftw not found in /usr/local/lib
  libraries rfftw,fftw not found in /usr/lib64
  libraries rfftw,fftw not found in /usr/lib
  fftw2 not found
  NOT AVAILABLE

dfftw_info:
  libraries drfftw,dfftw not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries drfftw,dfftw not found in /usr/local/lib64
  libraries drfftw,dfftw not found in /usr/local/lib
  libraries drfftw,dfftw not found in /usr/lib64
  libraries drfftw,dfftw not found in /usr/lib
  dfftw not found
  NOT AVAILABLE

djbfft_info:
  NOT AVAILABLE

  NOT AVAILABLE

gdk_x11_2_info:
  NOT AVAILABLE

agg2_info:
  NOT AVAILABLE

numarray_info:
  NOT AVAILABLE

blas_src_info:
  NOT AVAILABLE

fftw_threads_info:
  libraries rfftw_threads,fftw_threads not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries rfftw_threads,fftw_threads not found in /usr/local/lib64
  libraries rfftw_threads,fftw_threads not found in /usr/local/lib
  libraries rfftw_threads,fftw_threads not found in /usr/lib64
  libraries rfftw_threads,fftw_threads not found in /usr/lib
  fftw threads not found
  NOT AVAILABLE

_numpy_info:
  NOT AVAILABLE

gdk_info:
  NOT AVAILABLE

gtkp_x11_2_info:
  NOT AVAILABLE

sfftw_threads_info:
  libraries srfftw_threads,sfftw_threads not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries srfftw_threads,sfftw_threads not found in /usr/local/lib64
  libraries srfftw_threads,sfftw_threads not found in /usr/local/lib
  libraries srfftw_threads,sfftw_threads not found in /usr/lib64
  libraries srfftw_threads,sfftw_threads not found in /usr/lib
  sfftw threads not found
  NOT AVAILABLE

boost_python_info:
  NOT AVAILABLE

freetype2_info:
  FOUND:
    libraries = ['freetype', 'z']
    define_macros = [('FREETYPE2_INFO', '"\\"9.7.3\\""'), ('FREETYPE2_VERSION_9_7_3', None)]
    include_dirs = ['/usr/include/freetype2']

gdk_2_info:
  NOT AVAILABLE

lapack_src_info:
  NOT AVAILABLE

gtkp_2_info:
  NOT AVAILABLE

gdk_pixbuf_2_info:
  NOT AVAILABLE

amd_info:
  libraries amd not found in /net/easystreet/vol/homes/rroze/Python-2.6.2/lib
  libraries amd not found in /usr/local/lib64
  libraries amd not found in /usr/local/lib
  libraries amd not found in /usr/lib64
  libraries amd not found in /usr/lib
  NOT AVAILABLE

Numeric_info:
  NOT AVAILABLE

numerix_info:
numpy_info:
  FOUND:
    define_macros = [('NUMPY_VERSION', '"\\"1.3.0\\""'), ('NUMPY', None)]

  FOUND:
    define_macros = [('NUMPY_VERSION', '"\\"1.3.0\\""'), ('NUMPY', None)]

9) ldd /path/to/ext_module.so
ldd: /path/to/ext_module.so: No such file or directory


      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20090826/1f794c47/attachment-0001.html 


More information about the SciPy-User mailing list