[SciPy-User] SciPy under Windows 7 (x64)

David Cournapeau cournape@gmail....
Wed Dec 2 11:10:14 CST 2009

On Wed, Dec 2, 2009 at 11:26 PM, Bruce Southey <bsouthey@gmail.com> wrote:
> On 12/02/2009 07:19 AM, Donovan Parks wrote:
>> Hello Josef,
>>> David will know better, but can you try scipy-0.7.1 with numpy 1.3. to
>>> see whether this combination works on Windows 7 and to see whether
>>> your error is numpy 1.4.0 related? (I'm still not convinced that
>>> binary compatibility hasn't been broken.)
>> I moved to numpy 1.3 and indeed this fixed the problem. Thanks for the help.
>> Cheers,
>> Donovan
> While I saw the same error, I was able to do "import scipy.stats as
> stats" and the chi2 function appeared to be present (but I did not try
> it). So perhaps some variable(s) are not correctly defined.

I have seen the error on linux as well, and it was always related to
cython-generated code. I don't have the time to chase it right now,
but I suspect that it is a forward incompatibility, not a backward
compatibility (i.e. you have an extension built with numpy 1.4, and
then try to load it under numpy 1.3).

Starting from numpy 1.4.0, we have a way to check for this, and
multiarray will raise an exception whenever an extension built against
N is loaded under numpy M < N. Unfortunately, this will only work as
long both N and M are >= 1.4, so it is not very useful right now :)


More information about the SciPy-User mailing list