[SciPy-user] Problem with scipy.linalg and LAPACK.

John Hanks jbh@broad.mit....
Tue Feb 10 08:30:39 CST 2009

On Tue, Feb 10, 2009 at 7:16 AM, David Cournapeau
<david@ar.media.kyoto-u.ac.jp> wrote:
> John Hanks wrote:
>> I've repeated this using variations of every set of install
>> instructions for scipy that I can find with google with the same
>> result each time. Any suggestions about where to look for what I've
>> broken would be appreciated.
> Lapack 3.2 is not supported - please use 3.1.1 or below,

I went back and rebuilt everything from LAPACK 3.1.1 and forward and
still get the same error.

Here's my compiler settings:

ATLAS (from Make.inc)
   ICC = gcc
   ICCFLAGS = $(CDEFS) -fomit-frame-pointer -mfpmath=387 -O2
-falign-loops=4 -fPIC -m64
   SMC = gcc
   SMCFLAGS = -fomit-frame-pointer -mfpmath=387 -O2 -falign-loops=4 -fPIC -m64
   DMC = gcc
   DMCFLAGS = -fomit-frame-pointer -mfpmath=387 -O2 -falign-loops=4 -fPIC -m64
   SKC = gcc
   SKCFLAGS = -fomit-frame-pointer -mfpmath=387 -O2 -falign-loops=4 -fPIC -m64
   DKC = gcc
   DKCFLAGS = -fomit-frame-pointer -mfpmath=387 -O2 -falign-loops=4 -fPIC -m64
   XCC = gcc
   XCCFLAGS = $(CDEFS) -O -fomit-frame-pointer -fPIC -m64
   F77 = gfortran
   F77FLAGS = -fomit-frame-pointer -mfpmath=387 -O2 -falign-loops=4 -fPIC -m64
   SMAFLAGS = -fno-tree-loop-optimize
   DMAFLAGS = -fno-tree-loop-optimize

LAPACK (from make.inc)
    FORTRAN  = gfortran
    OPTS     = -O2 -fPIC -m64
    DRVOPTS  = $(OPTS)
    NOOPT    = -O0 -fPIC -m64
    LOADER   = gfortran

The numpy and scipy setup finds gfortran and produces a mostly
functional scipy install except for the undefined symbol error.



More information about the SciPy-user mailing list