[SciPy-user] Scipy 0.7, weave, windows

josef.pktd@gmai... josef.pktd@gmai...
Thu Jan 8 12:39:01 CST 2009

On Thu, Jan 8, 2009 at 1:22 PM, David Cournapeau <cournape@gmail.com> wrote:
> On Fri, Jan 9, 2009 at 3:12 AM,  <josef.pktd@gmail.com> wrote:
>> On Thu, Jan 8, 2009 at 12:37 PM, David Cournapeau <cournape@gmail.com> wrote:
>>> On Fri, Jan 9, 2009 at 1:13 AM,  <josef.pktd@gmail.com> wrote:
>>>> When testing weave with 'full', weave usually looks pretty good. It
>>>> leaves a lot of temp files behind, but  I don't get any failures or
>>>> errors. (after test with cout crash is removed)
>>> Hm, strange. I tried on another machine, and I still get a lot of
>>> those failures... Not the same though. Which compilers have you
>>> installed on your computer ? Do you have any MS compilers installed ?
>> Essentially only the official MingW 3.4.5, I also have an older
>> dev-cpp with separate MingW which is on the Windows path behind the
>> official MingW.
> Ah, that's why. The problems could only be seen when MS compiler were
> installed - I think I solve the problem - no errors anymore, now.

It would be useful to some users to have this information (e.g. in the
docs) if they run into similar problems.

I usually try to keep my Windows path clean, and it's also the reason
that I'm quite wary of automatic installers or programs that mess with
the registry.


More information about the SciPy-user mailing list