[SciPy-user] more build issues - slamch.o relocation R_X86_64_32S error

David Cournapeau cournape@gmail....
Mon Jan 26 09:57:15 CST 2009

On Tue, Jan 27, 2009 at 12:41 AM, christopher taylor
<christopher.paul.taylor@gmail.com> wrote:
> oh, the alias was done to force any calls to gfortran to actually call g77.
> i've tried this command:
>  ../configure -Fa alg -fPIC
> --with-netlib-lapack=/home/ctaylor/builds/lapack-3.1.1/lapack_LINUX.a
> and I modified make.inc with the following options:
> OPTS     = -O2 -fPIC
> NOOPT    = -O0 -fPIC

You got the same error as before ? The error message is quite
unambiguous: you have somwhere an object file compiled without the
-fPIC flag, and from your build log, it is a LAPACK file. Did you
clean everything before rebuilding, to be sure to start from scratch.

> i guess the follow on question is this, how do i tell ./setup.py to
> select g77 OR gfortran to execute with?

For atlas, it is -C if compiler_name
For LAPACK, you set it in the compilers
For numpy/scipy: python setup.py build --fcompiler=gnu95 will force
gfortran even if g77 is found.

But the problem posted originally is unlikely to be caused by g77/gfortran mix,


More information about the SciPy-user mailing list