[SciPy-User] [SciPy-user] 64-Bit Scipy on OS X

Dan Yamins dyamins@gmail....
Fri Jul 24 15:57:17 CDT 2009

> The solution that worked for Dan:
> LDFLAGS="-arch x86_64 -undefined dynamic_lookup -bundle" FFLAGS="-arch
> x86_64 -O2 -Wall -fPIC" python setup.py install
> does not work for me. The output of python setup.py install still has
> things like
> gfortran:f77:
> build/src.macosx-10.5-universal-2.6/scipy/stats/mvn-f2pywrappers.f
> /usr/local/bin/gfortran -Wall -Wall -undefined dynamic_lookup -bundle
> build/temp.macosx-10.5-universal-2.6/build/src.macosx-10.5-universal-2.6/scipy/stats/mvnmodule.o
> build/temp.macosx-10.5-universal-2.6/build/src.macosx-10.5-universal-2.6/fortranobject.o
> build/temp.macosx-10.5-universal-2.6/scipy/stats/mvndst.o
> build/temp.macosx-10.5-universal-2.6/build/src.macosx-10.5-universal-2.6/scipy/stats/mvn-f2pywrappers.o
> -L/usr/local/lib/gcc/i386-apple-darwin9.0.0/4.3.0
> -Lbuild/temp.macosx-10.5-universal-2.6 -lgfortran -o
> build/lib.macosx-10.5-universal-2.6/scipy/stats/mvn.so

I'm not an expert at doing this sort of thing either -- I think David
Cornapeau and Robert Kern are really the experts there -- but I would like
to ask if you have any more specific error message output during the
compile?  Are there any lines with a message like "not of proper
architecture" or something similar?   If you actually are able, could you
shunt all the output to a file, and attach it?  Maybe I could try to
diagnose the problem.  (Quite a few other things came up that had to be
solved _before_ the passing of the flags at the command prompt worked as a

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/scipy-user/attachments/20090724/55af81a3/attachment.html 

More information about the SciPy-User mailing list