[SciPy-User] Pytseries numpy func error

mudit sharma mudit_19a@yahoo....
Sun Nov 15 18:25:31 CST 2009

actually i figured that out it throws that error when data array is of dtype object

In [74]: data = npy.array([-1840.0,-1550.0,-940.0,2660.0,190.0,3980.0,1130.0,2090.0,1980.0,1220.0,-1220.0,1140.0,-2420.0,2200.0,370.0,230.0,-60.0,2550.0,970.0,660.0,-20.0,50.0,-980.0,6580.0,4090.0,3240.0,-350.0,-1800.0,2020.0,5050.0,-110.0,-330.0,-2290.0], dtype=npy.object)

In [75]: dates = "Mar-2007","Apr-2007","May-2007","Jun-2007","Jul-2007","Aug-2007","Sep-2007","Oct-2007","Nov-2007","Dec-2007","Jan-2008","Feb-2008","Mar-2008","Apr-2008","May-2008","Jun-2008","Jul-2008","Aug-2008","Sep-2008","Oct-2008","Nov-2008","Dec-2008","Jan-2009","Feb-2009","Mar-2009","Apr-2009","May-2009","Jun-2009","Jul-2009","Aug-2009","Sep-2009","Oct-2009","Nov-2009"

In [76]: series = ts.time_series(data,dates, freq="M")

----- Original Message ----
From: Matt Knox <mattknox.ca@gmail.com>
To: scipy-user@scipy.org
Sent: Tue, 10 November, 2009 22:29:41
Subject: Re: [SciPy-User] Pytseries numpy func error

> series.sum() gives this error whereas series.data.sum()
> works.

I don't get this error when trying a sum on a TimeSeries object. I noticed you
are using an older version of the timeseries module. Can you try upgrading to
the latest version and see if you still get an error? Also, if you still get
the error please post a small example demonstrating how to get the error,

Also, note that we will probably be doing a new minor bug fix release within
the next week or two.

- Matt

SciPy-User mailing list


More information about the SciPy-User mailing list